#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<=QUOTE )\d+"
Local $sString = "So# Comments" & @CRLF & _
"1 sjhsh QUOTE 234566" & @CRLF & _
"1 sdsds customer call QUote 239876 Call back" & @CRLF & _
"2 adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio " & @CRLF & _
"3 QUOTE 657894 customer called for service"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")