import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<=QUOTE )\\d+";
final String string = "So# Comments\n"
+ "1 sjhsh QUOTE 234566\n"
+ "1 sdsds customer call QUote 239876 Call back\n"
+ "2 adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio \n"
+ "3 QUOTE 657894 customer called for service";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}