package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(%n)(([:\+]\d+){0,2})`)
var str = `BOB-ROSS-%n:32+5000-%n:22+100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}