$re = '/(%n)(([:\+]\d+){0,2})/m';
$str = 'BOB-ROSS-%n:32+5000-%n:22+100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);