using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@media\b[^{]*({(?>[^{}]++|(?1))*})";
string input = @"@media only screen {
p {
color:red;
}
}
@media only screen and (max-width: 596px) {
p {
color:blue;
}
}
@media only screen {
}
img {
display: block;
}
@media only screen and (max-width: 240px) {
p {
color:green;
}
}
p {
font-weight: normal;
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}