re = /@media\b[^{]*({(?>[^{}]++|(?1))*})/
str = '@media only screen {
p {
color:red;
}
}
@media only screen and (max-width: 596px) {
p {
color:blue;
}
}
@media only screen {
}
img {
display: block;
}
@media only screen and (max-width: 240px) {
p {
color:green;
}
}
p {
font-weight: normal;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end