$re = '/(\d+),\1/i';
$str = '007,007,001,002,002,003,002,004,007,007';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);