using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([\S\s]*?)\]";
string input = @"[This regex tester
evaluates JavaScript regular expressions]
[This regex tester evaluates JavaScript regular expressions]
[This regex tester
evaluates JavaScript
regular expressions]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}