re = /\[([\S\s]*?)\]/
str = '[This regex tester
evaluates JavaScript regular expressions]
[This regex tester evaluates JavaScript regular expressions]
[This regex tester
evaluates JavaScript
regular expressions]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end