re = /(?:\G(?!^)|^(?!a))\D*\K\d+/m
str = 'abax 45456xx888z 89776uuu
bax 55456xx888z 99776uuu
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end