#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Content ID \[\d+\] ?"
Local $sString = "Content ID [9283745997] Content ID [9283005997] There can be text in between Content ID [9283745953] Content ID [9283741197] Content ID [928374500] There can be valid text here which should not be removed."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)