re = /Content ID \[\d+\] ?/
str = 'Content ID [9283745997] Content ID [9283005997] There can be text in between Content ID [9283745953] Content ID [9283741197] Content ID [928374500] There can be valid text here which should not be removed.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result