import re
regex = re.compile(r"(?<!\S)[0-9]{5,10}(?!\S)", flags=re.MULTILINE)
test_str = ("181523539532037 52844 072 301\n"
"BIC 55555 77777 9999999 554664\n"
"123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")