re = /(?<!\S)[0-9]{5,10}(?!\S)/m
str = '181523539532037 52844 072 301
BIC 55555 77777 9999999 554664
123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end