#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?x)" & @CRLF & _
".+(?:Sub|Function)\ (\w+)\( # method declaration" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
""
Local $sString = "Public Sub FindDictTreeNodes(ByVal startAtNodeDict As Scripting.Dictionary, ByVal searchKey As Variant, ByVal searchKeyItem As Variant, _" & @CRLF & _
" ByVal result As Collection, Optional ByVal childrenKey As Variant = "Children", Optional ByVal findOnlyFirst As Boolean, _" & @CRLF & _
" Optional ByVal searchAtLevel As Integer = 0, Optional ByVal useLikeOperatorForMatching As Boolean = False, _" & @CRLF & _
" Optional ByVal nowAtLevel As Integer)" & @CRLF & _
""
Local $sSubst = "#CSV list of parameters\n${2}, ${4}, ${6}, ${8}, ${10}, ${12}, ${14}, ${16}, ${18}, ${20}, ${22}, ${24}, ${26}, ${28}, ${30}\n\n#vertical list of parameters\n'${2} - \n'${4} - \n'${6} - \n'${8} - \n'${10} - \n'${12} - \n'${14} - \n'${16} - \n'${18} - \n'${20} - \n'${22} - \n'${24} - \n'${26} - \n'${28} - \n'${30} - \n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)