import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ ".+(?:Sub|Function)\\ (\\w+)\\( # method declaration\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n";
final String string = "Public Sub FindDictTreeNodes(ByVal startAtNodeDict As Scripting.Dictionary, ByVal searchKey As Variant, ByVal searchKeyItem As Variant, _\n"
+ " ByVal result As Collection, Optional ByVal childrenKey As Variant = \"Children\", Optional ByVal findOnlyFirst As Boolean, _\n"
+ " Optional ByVal searchAtLevel As Integer = 0, Optional ByVal useLikeOperatorForMatching As Boolean = False, _\n"
+ " Optional ByVal nowAtLevel As Integer)\n";
final String subst = "#CSV list of parameters\\n${2}, ${4}, ${6}, ${8}, ${10}, ${12}, ${14}, ${16}, ${18}, ${20}, ${22}, ${24}, ${26}, ${28}, ${30}\\n\\n#vertical list of parameters\\n'${2} - \\n'${4} - \\n'${6} - \\n'${8} - \\n'${10} - \\n'${12} - \\n'${14} - \\n'${16} - \\n'${18} - \\n'${20} - \\n'${22} - \\n'${24} - \\n'${26} - \\n'${28} - \\n'${30} - \\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}