import Foundation
let pattern = #"^([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+([^\s:]+):\s.*?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Sequence: 40 BR Name: ROUTE PARTIAL BR Description: ROUTE PARTIAL BR Action: AFTER ROUTE Enabled: Y"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\t\t\3\t\t\t\t\5\t\t\t\t\7\t\t\9\n\2\t\t\t\4\t\t\t\6\t\t\t\t\8\t10"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}