use strict;
my $str = 'dog dog dog cat cat fish
';
my $regex = qr/^(?>(\w+) (?=\1\b))+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";