$re = '/^(?>(\w+) (?=\1\b))+/';
$str = 'dog dog dog cat cat fish
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;