#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)ваша регулярка здесь - а флаги справа трогать не стоит"
Local $sString = "84951234567" & @CRLF & _
"+74951234567" & @CRLF & _
"8-495-1-234-567" & @CRLF & _
" 8 (8122) 56-56-56" & @CRLF & _
"8-911-1234567" & @CRLF & _
"8 (911) 12 345 67" & @CRLF & _
"8-911 12 345 67" & @CRLF & _
"8 (911) - 123 - 45 - 67" & @CRLF & _
"+ 7 999 123 4567" & @CRLF & _
"8 ( 999 ) 1234567" & @CRLF & _
"8 999 123 4567" & @CRLF & _
"" & @CRLF & _
"// выше - правильные, ниже - неправильные:" & @CRLF & _
"" & @CRLF & _
"02" & @CRLF & _
"84951234567 позвать люсю" & @CRLF & _
"849512345" & @CRLF & _
"849512345678" & @CRLF & _
"8 (409) 123-123-123" & @CRLF & _
"7900123467" & @CRLF & _
"5005005001" & @CRLF & _
"8888-8888-88" & @CRLF & _
"84951a234567" & @CRLF & _
"8495123456a" & @CRLF & _
"+1 234 5678901" & @CRLF & _
"+8 234 5678901" & @CRLF & _
"7 234 5678901" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)