import re
regex = re.compile(r"ваша регулярка здесь - а флаги справа трогать не стоит", flags=re.MULTILINE)
test_str = ("84951234567\n"
"+74951234567\n"
"8-495-1-234-567\n"
" 8 (8122) 56-56-56\n"
"8-911-1234567\n"
"8 (911) 12 345 67\n"
"8-911 12 345 67\n"
"8 (911) - 123 - 45 - 67\n"
"+ 7 999 123 4567\n"
"8 ( 999 ) 1234567\n"
"8 999 123 4567\n\n"
"// выше - правильные, ниже - неправильные:\n\n"
"02\n"
"84951234567 позвать люсю\n"
"849512345\n"
"849512345678\n"
"8 (409) 123-123-123\n"
"7900123467\n"
"5005005001\n"
"8888-8888-88\n"
"84951a234567\n"
"8495123456a\n"
"+1 234 5678901\n"
"+8 234 5678901\n"
"7 234 5678901\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)