# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"44999"
test_str = ("84951234567\n"
"+74951234567\n"
"8-495-1-234-567\n"
" 8 (8122) 56-56-56\n"
"8-911-1234567\n"
"8 (911) 12 345 67\n"
"8-911 12 345 67\n"
"8 (911) - 123 - 45 - 67\n"
"+ 7 999 123 4567\n"
"8 ( 999 ) 1234567\n"
"8 999 123 4567\n\n"
"// выше - правильные, ниже - неправильные:\n\n"
"02\n"
"84951234567 позвать люсю\n"
"849512345\n"
"849512345678\n"
"8 (409) 123-123-123\n"
"7900123467\n"
"5005005001\n"
"8888-8888-88\n"
"84951a234567\n"
"8495123456a\n"
"+1 234 5678901\n"
"+8 234 5678901\n"
"7 234 5678901\n")
matches = re.search(regex, test_str, re.MULTILINE | re.UNICODE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.