#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Username entry|user account) \((?P<Username>.*?)\).*(?P<MAC_address>(?:[0-9A-Fa-f]{2}[:-]){5}(?:[0-9A-Fa-f]{2}))(?:, IP address (?P<IP_address>\d+\.\d+\.\d+\.\d+))?"
Local $sString = "Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa" & @CRLF & _
"Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa" & @CRLF & _
"Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")