const regex = /(?:Username entry|user account) \((?P<Username>.*?)\).*(?P<MAC_address>(?:[0-9A-Fa-f]{2}[:-]){5}(?:[0-9A-Fa-f]{2}))(?:, IP address (?P<IP_address>\d+\.\d+\.\d+\.\d+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Username entry|user account) \\((?P<Username>.*?)\\).*(?P<MAC_address>(?:[0-9A-Fa-f]{2}[:-]){5}(?:[0-9A-Fa-f]{2}))(?:, IP address (?P<IP_address>\\d+\\.\\d+\\.\\d+\\.\\d+))?', 'g')
const str = `Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}