# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:https?:\\/\\/)?(?:www\.)?youtu\.?be(?:\.com)?\\/?.*(?:watch|embed)?(?:.*v=|v\\/|\\/)([\w\-_]+)\&?/$0\/modestbranding=1&rel=0/gm;t' <<< "http://www.youtube.com/watch?v=iwGFalTRHDA
http://www.youtube.com/watch?v=iwGFalTRHDA
http://youtu.be/embed/iwGFalTRHDA
http://youtu.be/n17B_uFF4cA
http://www.youtube.com/embed/iwGFalTRHDA
http://youtu.be/t-ZRX8984sc
https://www.youtube.com/embed/UIpuNuV23v0"