import re
regex = re.compile(r"(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/?.*(?:watch|embed)?(?:.*v=|v\/|\/)([\w\-_]+)\&?", flags=re.MULTILINE)
test_str = ("http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"http://youtu.be/embed/iwGFalTRHDA\n"
"http://youtu.be/n17B_uFF4cA\n"
"http://www.youtube.com/embed/iwGFalTRHDA\n"
"http://youtu.be/t-ZRX8984sc\n"
"https://www.youtube.com/embed/UIpuNuV23v0")
subst = "$0/modestbranding=1&rel=0"
result = regex.sub(subst, test_str)
if result:
print(result)