use strict;
my $str = 'Strings with negative numbers do not match. Leading
0\'s do not match, except when a number is 0.
0, 0, 0
211, 111, 011
000, 160, 255
Strings with a numeric value over 255 do not match
255, 255, 255
255, 255, 256
4-Digit numbers will not match
1, 11, 111
11, 111, 1111
Strings that contain more, or less, than 3 numbers, do
not match. Strings with dangling commas do not match.
111, 122, 133
111, 122, 133, 144
111, 122, 133,
111, 122
111
Numbers 0-9 are valid as long as the numbers they are used
to form are between 0 and 255
209, 183, 245';
my $regex = qr/^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}