import re
regex = re.compile(r"^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])$", flags=re.MULTILINE)
test_str = ("Strings with negative numbers do not match. Leading\n"
"0's do not match, except when a number is 0.\n"
"0, 0, 0\n"
"211, 111, 011\n"
"000, 160, 255\n"
"Strings with a numeric value over 255 do not match\n"
"255, 255, 255\n"
"255, 255, 256\n"
"4-Digit numbers will not match\n"
"1, 11, 111\n"
"11, 111, 1111\n"
"Strings that contain more, or less, than 3 numbers, do \n"
"not match. Strings with dangling commas do not match.\n"
"111, 122, 133\n"
"111, 122, 133, 144\n"
"111, 122, 133,\n"
"111, 122\n"
"111\n"
"Numbers 0-9 are valid as long as the numbers they are used \n"
"to form are between 0 and 255\n"
"209, 183, 245")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")