$re = '/([\[,]\s*)([A-Za-z_]\S*)(?=,|\s*\])/m';
$str = '[ 0, 0, Header, 1, 17, 480 ],
[ 1, 0, Start_track ],
[ 1, 0, Title_t, "Dance of the knights (Romeo & Juliet)" ],
[ 1, 0, Tempo, 600000 ],
[ 1, 0, Time_signature, 4, 2, 24, 8 ],
[ 1, 0, Key_signature, 1, "major" ]';
$subst = "$1\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;