#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<BG SWITCH>(.*)\n\s*(\s*<BG CASE>(.*):\n\s*(.*)\n\s*<BG \/CASE>)+\n\s*<BG \/SWITCH>)"
Local $sString = "<div>" & @CRLF & _
" Some other content before" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
" <BG SWITCH>param1" & @CRLF & _
" <BG CASE>value1:" & @CRLF & _
" text 1" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value2:" & @CRLF & _
" text 2" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value3:" & @CRLF & _
" text 3" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value4:" & @CRLF & _
" text 4" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG /SWITCH>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
" Some other content between" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
" <BG SWITCH>param2" & @CRLF & _
" <BG CASE>value1:" & @CRLF & _
" text 1" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value2:" & @CRLF & _
" text 2" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value3:" & @CRLF & _
" text 3" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value4:" & @CRLF & _
" text 4" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG /SWITCH>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
" Some other content after" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")