$re = '/(<BG SWITCH>(.*)\n\s*(\s*<BG CASE>(.*):\n\s*(.*)\n\s*<BG \/CASE>)+\n\s*<BG \/SWITCH>)/';
$str = '<div>
Some other content before
</div>
<div>
<BG SWITCH>param1
<BG CASE>value1:
text 1
<BG /CASE>
<BG CASE>value2:
text 2
<BG /CASE>
<BG CASE>value3:
text 3
<BG /CASE>
<BG CASE>value4:
text 4
<BG /CASE>
<BG /SWITCH>
</div>
<div>
Some other content between
</div>
<div>
<BG SWITCH>param2
<BG CASE>value1:
text 1
<BG /CASE>
<BG CASE>value2:
text 2
<BG /CASE>
<BG CASE>value3:
text 3
<BG /CASE>
<BG CASE>value4:
text 4
<BG /CASE>
<BG /SWITCH>
</div>
<div>
Some other content after
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);