const regex = /_(.*)_/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(.*)_', '')
const str = `bla_bla, bla, bla_bla_bla, bla_bla_bla_bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}