#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(C[[:alpha:]]*)(\d*)(.*)$"
Local $sString = "indSIMDdecile" & @CRLF & _
"CSdeccrim12006" & @CRLF & _
"CSdeccrim12006" & @CRLF & _
"CSdeccrim12009" & @CRLF & _
"CSdeccrim12009" & @CRLF & _
"CSdeccrim12012" & @CRLF & _
"CSdeccrim12012" & @CRLF & _
"CSdeceduc12004" & @CRLF & _
"CSdeceduc12004" & @CRLF & _
"CSdeceduc12006" & @CRLF & _
"CSdeceduc12006" & @CRLF & _
"CSdeceduc12009" & @CRLF & _
"CSdeceduc12009" & @CRLF & _
"CSdeceduc12012" & @CRLF & _
"CSdeceduc12012" & @CRLF & _
"CSdecemp12004.x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")