import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(C[[:alpha:]]*)(\\d*)(.*)$";
final String string = "indSIMDdecile\n"
+ "CSdeccrim12006\n"
+ "CSdeccrim12006\n"
+ "CSdeccrim12009\n"
+ "CSdeccrim12009\n"
+ "CSdeccrim12012\n"
+ "CSdeccrim12012\n"
+ "CSdeceduc12004\n"
+ "CSdeceduc12004\n"
+ "CSdeceduc12006\n"
+ "CSdeceduc12006\n"
+ "CSdeceduc12009\n"
+ "CSdeceduc12009\n"
+ "CSdeceduc12012\n"
+ "CSdeceduc12012\n"
+ "CSdecemp12004.x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}