using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({%)\s*(tag)([^%}]*?)(?:\s*(?:(%})((?:(?:[^{%]*?)|(?R))*)(?:({%)\s*(end\2)\s*(%}))))";
string input = @"{% tag xyz %}
{% tag abc %}
{% endtag %}
{
{% endtag %}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}