package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}(?:\.\d+)?))(Z|[\+-]\d{2}:\d{2})?)$`)
var str = `2016-01-19T15:21:32.59+02:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}