re = /^((?:(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}(?:\.\d+)?))(Z|[\+-]\d{2}:\d{2})?)$/m
str = '2016-01-19T15:21:32.59+02:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end