using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)\s+(.*?)\s+(.*?:)(.*)";
string input = @"/exe c:\dos\main.cpc /l:check";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}