const regex = /(?<tag>(?&TAG)):\s*
(?<message>.*?)
(
<
(?<author>(?:\w{3}\s*,\s*)*\w{3})?\s*
(?<date>(?&DATE))?
(?<flags>(?&FLAGS))?
>
)?
$
(?(DEFINE)
(?<TAG>\b(NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG))
(?<DATE>\d{4}-\d{2}-\d{2})
(?<FLAGS>[pts]:\w+\b)
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<tag>(?&TAG)):\\s*
(?<message>.*?)
(
<
(?<author>(?:\\w{3}\\s*,\\s*)*\\w{3})?\\s*
(?<date>(?&DATE))?
(?<flags>(?&FLAGS))?
>
)?
$
(?(DEFINE)
(?<TAG>\\b(NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG))
(?<DATE>\\d{4}-\\d{2}-\\d{2})
(?<FLAGS>[pts]:\\w+\\b)
)', 'gm')
const str = `// NOTE: A small example
// HACK: Another example <ABC 2014-02-03>
// HACK: Another example <ABC,DEF 2014-02-03>
// HACK: Another example <ABC,DEF p:0>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}