package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\w{3})\w+)`)
var str = `I am batman
I am superman
I am ironman`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}