$re = '/((\w{3})\w+)/';
$str = 'I am batman
I am superman
I am ironman';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);