$re = '/\b[^,]*car[^,]*\b/m';
$str = 'typography,caret,car,card,align,shopping-cart,adjust,allineate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);