re = /\b[^,]*car[^,]*\b/m
str = 'typography,caret,car,card,align,shopping-cart,adjust,allineate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end