$re = '/(?<time>(?:\d+ hrs?)?\s*(?:\d+ mins?)?\s*(?:\d+ secs?)?\s*(?:\d+ ms)?)/m';
$str = '2 hrs 2 mins 36 secs 312 ms
1 hr 2 mins 36 secs 312 ms
312 ms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);