re = /(?<time>(?:\d+ hrs?)?\s*(?:\d+ mins?)?\s*(?:\d+ secs?)?\s*(?:\d+ ms)?)/m
str = '2 hrs 2 mins 36 secs 312 ms
1 hr 2 mins 36 secs 312 ms
312 ms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end