const regex = /"([^"]+)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]+)"', '')
const str = `[assembly: AssemblyVersion("1.0.0.0")]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}