$re = '/"([^"]+)"/';
$str = '[assembly: AssemblyVersion("1.0.0.0")]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);