package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d),([a-z])(?:\||$)`)
var str = `1,a|2,b|3,c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}