$re = '/(\d),([a-z])(?:\||$)/i';
$str = '1,a|2,b|3,c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);