#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:a{3}(?!a(?:[^a]|$))|a{2})"
Local $sString = "aa" & @CRLF & _
"aaa" & @CRLF & _
"aaaa" & @CRLF & _
"aaaaa" & @CRLF & _
"aaaaaa" & @CRLF & _
"aaaaaaa" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"aaaaaaaaa" & @CRLF & _
"aaaaaaaaaa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")